The Watch Site banner

1 - 6 of 6 Posts

·
Registered
Joined
·
626 Posts
Discussion Starter #1
Hello wonderful folks,

I recently was lucky enough to get a basically unworn Seiko S966-4010 talking watch from 1982 - original inner and outer boxes, caseback sticker, etc. However, when I popped in a new battery and tried to test the thing out, it's acting wonky in a very weird way. Bear with me while I try to explain how, if you will...

At first, I thought the speaker was busted, because I can't get the talking watch feature to work in any of the ways it's supposed to for normal time. The "speak" button does nothing when its depressed under normal time mode, and the "timer" function (where it's supposed to keep speaking the number of minutes elapsed each minute) doesn't work, even though the little flashing "T" does show up on the screen.

BUT when I put the watch in alarm mode, and turn the alarm off, I can get the speaker to say "Alarm Off" by pushing the speaker button (which is 100% what it's supposed to do, per the manual). But when I have the alarm on, and I push the speak button, it says "Alarm" and nothing else. Per the manual and videos on youtube, it should be saying "Alarm" followed by the time the alarm is set for. I'm even able to change the watch from English to Spanish per the manual, and I can get the lady to then say "No Alarma" or "Alarma," but again it leaves off the alarm time. Like it somehow can't internally "read" what I've set it for?

Even stranger, I am able to turn the speaker mode "off" and "on" as the manual suggests, and when I push the speaker button while it is in "off" mode, the screen changes to say "off." Again, manual says that's exactly what it's supposed to do. But when the speaker mode is on, it just doesn't do anything.

Any idea why on earth it would be doing this, and whether/how it could be repaired to work right? It's as if it can't "read" the time at all, even though the speaker works. Maybe its some weird glitch with the circuitry?

Cheers!
 

·
Registered
Joined
·
420 Posts
Was there any evidence of battery leakage (white crystals, liquid etc) when you changed the battery?

This is a very common problem with watches of this age. As it is a liquid, the battery acid can get in all manner of places (depending on how the watch was stored) and cause all manner of problems.

Sometimes on first inspection all looks OK and its only when you investigate fully (by taking things apart) that you find out what has happened.

All that said, it may be something else entirely, and possibly just age related circuit failure.
 

·
Registered
Joined
·
626 Posts
Discussion Starter #3
Thanks much, Alan. As far as I could tell, no obvious battery leakage - looked clean enough on the inside, but I didn't take apart the movement. I suppose if the battery leaked into one particular part of the circuit it could cause this? I'm usually a mechanical guy so I'll plead ignorance. Anyway, sounds likely that it's not a repairable issue, but if anyone else has any ideas I'd take them!
 

·
Registered
Joined
·
4,911 Posts
Did you reset the movement after the new battery was fitted?
 

Attachments

·
Registered
Joined
·
626 Posts
Discussion Starter #6
Guys, I have no idea how I missed that in the manual but it worked like a charm! It's now fully functional. Thanks!!!
 
1 - 6 of 6 Posts
Top