The Watch Site banner

1 - 10 of 10 Posts

·
Registered
Joined
·
535 Posts
Discussion Starter · #1 ·
I got this swiss military and in my effort to reset the hands to zero I have lost the function of the dial at 6 o'clock. 1/10th sec and hr chrono dial.
I did see it spin once after battery replacement but before zero reset.
Just wondering if any learned folk have come across this issue in either a Ronda or any other movement for that matter... And possible fixes.
 

·
Registered
Joined
·
6,720 Posts
Hey that is what happened on my Chase...i am told it is the old oils ....it probably needs a service...what i did to get mine to work temporary was to get it warm...it reset just fine after that..what is the movement number?...God Bless John
 

·
Registered
Joined
·
845 Posts
Frequently there is a zero reset and an ALL RESET procedure. The latter is usually required after a battery change...but may be required after em/static charge issues. What caliber? Download the tech sheet and try the reset procedure.

BTW...this is the Japanese->Main Forum->Watchmaking...Rhonda is Swiss...?

Regards, BG
 

·
Registered
Joined
·
6,720 Posts
it might just be something simple too
 

·
Registered
Joined
·
535 Posts
Discussion Starter · #5 ·
Cheers. I will let you know how I go with calibre number and reset.

I wasn't aware there was a separate tinkering for non Japanese. I'm using that tap talk. I'm sorry if I made an Error.
Im with you John. I hope it's simple. It's a cool looking watch and may replace the spot for swiss chrono, currently held by my tissot v8.
 

·
Registered
Joined
·
6,720 Posts
well i would try and warm it up first...but more than likely it needs to be serviced..and definately go thru the reset procedure...
 

·
Registered
Joined
·
535 Posts
Discussion Starter · #7 ·
I've done a crown at 3rd position double button press reset but I'm hoping there is a battery out or AC static reset also. Will try warming it. Although it's 33 deg Celsius here and I was waring it so it probably wouldn't need much more warmth than that.
 

·
Registered
Joined
·
535 Posts
Discussion Starter · #8 ·
The movement is 5040.d from the ronda instructions the only reset is the two button press with 3rd position crown. Not sure if there is anything else.
 

·
Registered
Joined
·
6,720 Posts
well i am not familiar with that model...have you tried a new battery first?...how old is the watch?..
 

·
Registered
Joined
·
845 Posts
1. Did the chronograph functions work (if even from the incorrect hand reset positions) before you attempted to reset the zero positions?
2. Is this the reset procedure you followed: http://hanowa.ch/Users-Manuals/Manual-RL5040D-S-M-H-engl.pdf ?
3. Haven't viewed this...but might be helpful (or completely misleading): https://www.youtube.com/watch?v=cAps7dE9CP0

If you followed the reset procedure and if the movement still does not work correctly, follow analysis of the circuit functions as set forth in the tech sheet. (There does not appear to be an ALL RESET function for this movement).

Looks like movements are available for <$50...so replacement might be a reasonable option.

Regards, BG
 
1 - 10 of 10 Posts
Top