The Watch Site banner

1 - 9 of 9 Posts

·
Registered
Joined
·
2,974 Posts
Discussion Starter #1
I received my Citizen Quartz Crystron # 44-0019 today and it does definitely need some work (I knew that ahead of thime tho) but I am stumped!!
I am trying to remove the bezel insert and there is a Black plastic piece under the bezel itself with a notch located in the 12:02 (appx) position which I "assume" is meant for the bezel spring to attach into!? Is the Black plastic piece AND the insert ALL one integral part or should the isert be able to pried off like any other watch insert?
(pic attached)
Also.......... the battery that is in it is definitely the incorrect one as it IS way too thick. (Currently it has a Energizer # 386/301 in it ) The watch itself will work but the hands will sometimes instead of moving forward will click backwards 2 seconds or so and then they will somewhat reluctantly move forward as they should! Is this because the battery is the wrong one or does it denote something else?
I am really stumped!!
Thanks for any help anyone might be able to offer!

(The black bezel insert piece)


The Bezel spring clip(s)



The watch itself so you will know which model I am talking about.



PS.... I almost forgot to ask........ does anyone know where I can buy a X-tal for this one as it is beyond the use of polywatch!
Thank you!!
 

·
Registered
Joined
·
2,974 Posts
Discussion Starter #2
OK.......never mind the bezel insert question....... I got that problem fixed! Now what I still need to know is why the 2nds hand jumps backwards for a few seconds then returns to running forward as normal!
 

·
Registered
Joined
·
2,974 Posts
Discussion Starter #4
Right now it's not doing anything! I put the battery back into it that it came with and now it's not even working!
I am still trying to figure out the exact model battery it's supposed to have as I dont find my model # listed on any of the charts!
 

·
Registered
Joined
·
2,974 Posts
Discussion Starter #6
Yep...... contacts are as clean as a whistle.
I also received a reply from another Forumer who tells me that the correct batter is supposed to be a 301
I dont have a 301 so I guess I'll have to spend another $5.00 and try it to see if that one works!?
Right now I'm having probs in getting out the movement! I cant find the correct button to push to release the stem assembly!
 

·
Registered
Joined
·
119 Posts
Regarding your erratic seconds hand - looking at the movement pic you posted in your other thread (I assume that it's the same watch?), there's a part that's been displaced. Just above the "S" in "ADJUSTED" there's a pivot and jewel. The spring strip that's just to the left of this should actually be centred over the pivot. It controls end shake, and puts a braking load on the arbor. Without it, the seconds hand will wander.
Loosen the screw, reposition the strip, and tighten the screw.
 
1 - 9 of 9 Posts
Top