The Watch Site banner

1 - 3 of 3 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter #1
Not much point in posting the "same old - same old" picture of my baby Arnie on the WRUW thread. It's what I wear all the time. That might change shortly as I'm waiting on a bracelet for the fabulous Belle recently received from The Tiger (obviously before the ash cloud troubles). Now there's a gentleman you can deal with in confidence - thanks John!

A month back - see: http://www.network54.com/Forum/78440/message/1269028707/Having+a+clearout+of+junk- I sent out several packages of odds and ends to the US, the UK and France. Wouldn't you know it the only one not received went Canada Post/USPS. I knew it had to happen sooner than later, but why now, after all these years of never having anything lost in the mail?

Last week I was given a couple Seikos, not working of course. The A127 worked like a charm with a new battery (a pig to figure out the settings, but finally did). Unfortunately, the original bracelet had been so hacked up it was beyond repair. I popped on a S/S one I had on hand pending the decision as to what I'll put on it
(Suggestions welcome).




The 5M43 is another story. With a vigorous shaking, it will run for a few minutes then stop. My Sherlock Holmes deductive powers :) suggested maybe the capacitor was bad, so a new one is on it's way. If that fixes it, I'll have my first 'Kinetic" and also my first 'Titanium' watch (this one came from Saudi Arabia I think, as the day wheel is Arabic/English). If not, I have another junker on which I wasted a few bucks for parts.

Enjoy your day folks :)

Cheers! Hamish.
 

·
Registered
Joined
·
44 Posts
I had a 5M43 nearly identical to that once. When I got it, it wouldn't hold a charge so I did what any would be watch hack like myself would do, and ordered a replacement battery for it. Well it arrived and when I opened it up, the weight had come lose from the stamped part of the rotor assembly. So that's why it wouldn't take a charge....... ??? . Well I took the bits out and reattached the weight to the rotor, and while I had it out, I went ahead and replaced the battery since I had it. All worked well once I got it back together.
 

·
Registered
Joined
·
1,680 Posts
I bought an identical Kinetic lNOS in Mexico for about USD 100 a few years back but was not wearing it much. Had problems at the end and took it to a watch place in the US. When the guy that took it apart told me that he would not be able to repair because of a lot of Bull...Seeing the poor watch with its guts sticking out, I just lost interest and left it there. The guy was going to ask for a ton of money for the repair. Hope he was able to fix it and put it to good use.
 
1 - 3 of 3 Posts
Top