The Watch Site banner

21 - 40 of 53 Posts

·
Registered
Joined
·
6,663 Posts
well before i would go to jeweler...put a ad on the trading forums...it should help
 

·
Registered
Joined
·
5 Posts
Probably a good idea, but it's a really basic item.. in this thread, if you back up a few posts, you'll see a nice clear shot of a C300 movement.. with the Diamond shaped battery clip/strap in place. I just need One of those. I'd think they'd be easy to deal with, but apparently not.... :)
 

·
Registered
Joined
·
6,663 Posts
well i do not see a pic of it
find one or take one and put a wtb on the trading post
you will surprised how many people find what they need right here on the forum...
if you can not locate one
let me know
i will try and help
God Bless John
 

·
Registered
Joined
·
5 Posts
jringo... I can't post links/pix yet, so if you would, scroll up to Sir Alan's picture above our posts. It's a rather large picture of a C300 movement. He's indicated the screws and points in order to remove the movement, but I would direct your attention to the battery and the diamond shaped strap/clip that is in the lower left of the movement. I'm attempting to find that diamond shaped piece online and not having much luck.

I do suspect a Citizen jeweler would have one perhaps, or I can certainly send the watch in for regular repairs, but that seems silly just for a small clip like that.

Thank you!
 

·
Registered
Joined
·
6,663 Posts
ok...so you need the battery hold down..well that item a citizen dealer i would think they should have...i would also put a ad in the trading post....someone here might have exactly what you need too...God Bless John...
 

·
Registered
Joined
·
5 Posts
got it.. thank you John! I work not far from a mall, and I know at least a couple of jewelers in there carry Citizen/seiko and others. I'll stop by during lunch or something.

I've looked and looked for the original--it just sprung away when I was tucking one tip into the movement and it's gone. I tried a magnet, vacuuming the floor, etc. and nothing--like it just disappeared into thin air :)

Thanks again!
 

·
Registered
Joined
·
6,663 Posts
well once you buy a new one...you will find it..that is what always happens to me...please keep up updated..God Bless John
 

·
Registered
Joined
·
3 Posts
I am very happy to have this watch working again. I am a bit scared to have it break again. I am thinking of getting a deluxe repair kit and a c300 movement preemptively.
And some watch repair reading material, this forum has gotten my interest.
. . . I wore it all for the last couple of days, it is brilliant. It is just strange the world time is only accurate in Sydney. I could move i guess..
 

·
Registered
Joined
·
6,663 Posts
well great..love hearing that is back on the wrist...well i am sure the movement may need a service but great work getting it going again...i have a Chase Durer and i have to service it too but remember the worst you can do is break it...we can always figure out how to fix it if you do..just enjoy it...God Bless John
 

·
Registered
Joined
·
3 Posts
Hi there, I also own a citizen skyhawk blue angels edition, a C300 one but all of the sudden the Mode button does not work, it press it and press it and the mode never changes, or I hold it pushed down and the digital numbers don't blink like they are supposed to, what would you guys recommend me to do/check?, thanks in advance for any help/advice you can give.
 

·
Registered
Joined
·
3 Posts
Hi I am no expert but I believe this is a common problem. The inner working the mode button pushes against gets worn out, a tab of some sort, but i could be wrong. I had the same problem about ten years ago and had a citizen repair shop do the repair. Which is another story.
Hopefully some one with specific knowledge will have a better answer. I have only just started to tinker with watches.
good luck
 

·
Registered
Joined
·
238 Posts
Hi there, I also own a citizen skyhawk blue angels edition, a C300 one but all of the sudden the Mode button does not work, it press it and press it and the mode never changes, or I hold it pushed down and the digital numbers don't blink like they are supposed to, what would you guys recommend me to do/check?, thanks in advance for any help/advice you can give.
That will be a matter of removing the case back and watch what happens when you press that particular pusher. You will also need to check that the tab the pusher presses against is in place and is being correctly operated by the pusher.

David
 

·
Craftsman
Joined
·
509 Posts
Hi there, I also own a citizen skyhawk blue angels edition, a C300 one but all of the sudden the Mode button does not work, it press it and press it and the mode never changes, or I hold it pushed down and the digital numbers don't blink like they are supposed to, what would you guys recommend me to do/check?, thanks in advance for any help/advice you can give.
Each time you push the mode button in, the small hand at the 6pm sub dial hand should move clockwise to point to the next mode.

When you pull the mode button out to the first 'click' position the watch should go into SET mode - typically this will cause the main LCD segment digits to flash.

So, can you try pulling the mode button out. What happens?

Now push the mode button back in (to the normal position).

Now try and push it in, you should feel a definite click, and the 6pm hand should move to the next mode.

If this isn't happening then it is possible that there is gunge behind the pusher preventing it from travelling in as far as it should. This is VERY common on old watches that have been worn. To sort this out you will need to remove the button and stem and inspect and clean the cavity the pusher fits into.

It is also possible that the movement is damaged from abuse (I've had two of these watches with broken stems which can only happen from severe force). There isn't a simple fix to this I'm afraid (it depends what is damaged).
 

·
Registered
Joined
·
3 Posts
Thank you very much that worked, it took two clicks after pulling it up, but it finally changed mode and I was able to put it on the time mode, I didn't see any of that in the manual I got, I really appreciate the useful advice!.
 

·
Registered
Joined
·
8 Posts
I have what I believe is the OPPOSITE problem. I can pull the mode button out (this works with a solid click), but the digits do not flash. The other pushers seem to work, as I can start the chrono, etc. But I cannot set an alarm or the countdown timer.

It's like the button comes out, but the movement doesn't realize it.

Does anyone have ideas on this one?
 

·
Registered
Joined
·
1 Posts
Hello all. First post on this forum.

I have a first generation red/back Navihawk that I picked up used about a year ago. I have no idea of the history of it but it is in great physical shape. I hadn't worn it in awhile and pulled it out of my watch case and noticed that the LCD is faint when viewing it head on. It looks fine when viewing at a slight angle.

Does this seem like its most likely a battery issue or could my LCD be going out? I have done some research and it seems like silver oxide batteries are preferable over alkaline, I guess that should be my first step.

Thanks in advance for the help
 

·
Registered
Joined
·
546 Posts
Hello all. First post on this forum.

I have a first generation red/back Navihawk that I picked up used about a year ago. I have no idea of the history of it but it is in great physical shape. I hadn't worn it in awhile and pulled it out of my watch case and noticed that the LCD is faint when viewing it head on. It looks fine when viewing at a slight angle.

Does this seem like its most likely a battery issue or could my LCD be going out? I have done some research and it seems like silver oxide batteries are preferable over alkaline, I guess that should be my first step.

Thanks in advance for the help
Hi and welcome.

You should start your own thread.

Are you sure you are 100% looking at it perfectly straight? Most of the leds on watches have a pretty poor viewing angle. So if you see it darker at a different angle you might actually be lining up better.

I would think you have silver oxide for a battery now

Sent from my LGLS660 using Tapatalk
 

·
Registered
Joined
·
10 Posts
new battery just installed into a c300 movement

Hello fellow Citizen navahawk watch owner, I have the c300 movement and the first battery died (many yrs ago) so i JUST put in a new one in today Feb 28 2016. The instructions i have found to "short (AR) terminal and (+) of the battery twice" are just not clear enough to me. I need much more detail in actually what the " + " spot i am suppose to push (it does not seem to be clearly marked as what to push !! ) and the terminology of "shorting" the AR terminal is not exactly explaining what i am suppose to do there either. Can you help me on this? Possibly speaking on the phone might be the fastest to explain this so if you send me an email directly we can work that. thanks larry
 
21 - 40 of 53 Posts
Top