The Watch Site banner

1 - 8 of 8 Posts

·
Registered
Joined
·
532 Posts
Discussion Starter #1
Just wondering what the light is supposed to look like on these guys.
Picked this one up from the watch collector.
It works except for the top left light button.
looks pretty clean inside, wondering if this is a common problem and or a nasty fix
 

·
Registered
Joined
·
4,929 Posts
I don't 100% know, but I think those would have an old style bulb, so I'd first check the battery voltage, second check the pusher button is making contact and is clean.
Other than that - you'll have to strip it down a little and check voltage at the bulb/ continuity of the bulb with a meter, the problem is that the parts are unavailable from Citizen and you'll likely have to get a similar bulb from another Lithium batteried watch (Casio maybe)?
Chris Galbraith may be a good guy to talk to about Aqualands and part numbers, Good luck.
http://www.pmwf.com/Watches/CitizenTable.htm#Diver200DataTransferSystem
 

·
Registered
Joined
·
3,881 Posts
Aloha camrok,
That website given has the spread look for it. That's your watch.
__________________________________________________
The light is almost the same placing as those C230 , etc.
In the back of the Digital Screen there is a little contact for the Digital parts to work, It might look like these in the picture below.
In those C230's also if the strip is not contacting the Board it will now supply the power for it.
_________________________________________________________________
Yours :
It has a little (Bulb in that model ) also, and could be weak to power up.
Maybe the contacts.
_________________________________________________________________
But if it similar to :
If it has those strips like the C230's :
It might be dirty, or little loose. It has like a (sticky film) on the little strip to stay in place onto the board.
The C506's are similar to these I would think.
Look and see the parts spread in the first picture.
____________________________________________
The top shows the Digital window parts apart. ( click on the first picture to view it. )
____________________________________________
On the window lens, the (little strip) on the window is the contact ( Strip ) for the power to display from the board.
In the Second picture it shows the Lends and the strip better .....(below the ( D M ) letters and how it is attached to the window.
It should be similar to these C023's , maybe a little different. It could be not contacting or dirty some where in between.
Not totally sure but it might be that.
On the C230 Aqualands I have to clean that (misty looking soft film) one really good so as for it to show clearly on the Digital
I just wipe it good with a ...Q-tip that's all.
Also I found to do that in (only one direction) so as it not to smear the film part. No chemicals needed to use.
The power for it comes through the strip that is stuck to the Lends and to the board.
Hope this helps a little.
 

Attachments

·
Registered
Joined
·
4,929 Posts
Back to factory repair only, so Citizen don't generally sell spare parts- unless they also happen to fit a non factory fix watch movement.
 
1 - 8 of 8 Posts
Top