The Watch Site banner
1 - 5 of 5 Posts

· Registered
Joined
·
526 Posts
Discussion Starter · #1 ·
I purchased a rather nice looking 0634 5019 and although in working condition it was acting ''funny'' i mean when pressing the chrono button the display goes blank for some time plus i could not set the time for the same reason(pulling the crown and pressing the buttons make the display blank for some time).

I opened the hatch and a wrong battery was fitted(if i remember corectly a 391 battery).
I tried with 2 diferent brand new 386 silver oxide bateries and the watch is dead,i mean no LCD no backlight, nothing.
Putting back the ''wrong'' battery and the watch ''works'' ofcourse with the issues mentioned above.

I checked the new batteries and no issues with the voltage,both good,the connections also looking pretty clean in my eyes(although not an expert).

Any ideas guys before having an expert to have it checked?:confused:
 

· Registered
Joined
·
526 Posts
Discussion Starter · #4 ·
You will probably find soon the light stays on and you have to pull the crown to turn it off
Exactly,i noticed this light issue with the 391 battery.


Do you think we can save it Seikokid?

Or i start looking for a donor watch,i mean the externals are in pretty good shape,not mint but still good enough.
 

· Registered
Joined
·
526 Posts
Discussion Starter · #10 ·
According to the latest Seiko list - it's an SR43W.
Battery manufacturers have, over the years reduced the number of batteries they make and have made a few sizes multi -fitment - with the result of batteries not fitting correctly.
Therefore a modern 386 may not have the correct dimensions, this is a known problem, and has been discussed on the forum before.
I wasn't aware of this,meaning that possibly the 386 from the 70's isn't the same size with a modern 386 :confused:
 

· Registered
Joined
·
526 Posts
Discussion Starter · #11 · (Edited)
.....sound like a job for The SeikoKid :)

Reviving this old thread for a status update :grin:


Seikokid did his ''vintage LCD kind of magic '',fixed the watch and the 0634 is back on the wrist,all functions working corectly and so far with a great timekeeping.Couldn't be happier i love the style of this particular model,the built quality is amazing and the fact that the watch is working great made my week :dance:


Thank you Seikokid,Tiger and all forum members for the advices and suggestions!














 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top